Skip to content

Installation

React-Auth-Kit is available as a npm package

npm

To install and save in your package.json dependencies, run:

//with npm
npm install --save react-auth-kit

//with yarn
yarn add react-auth-kit
Please note that react >= 16, js-cookie = 2.2.1 and react-router-dom = 5.2.0 are peer dependencies.

CDN

You can start using React-Auth-Kit with minimal infrastructure, which is great for prototyping.

Two Universal Module Definition (UMD) files are provided:

You can follow this CDN example to quickly get started.

Using this approach in production is discouraged though - the client has to download the entire library, regardless of which components are actually used, affecting performance and bandwidth utilization.

The UMD links are using the latest tag to point to the latest version of the library. This pointer is unstable, it shifts as we release new versions. You should consider pointing to a specific version, such as v1.4.6.

— 🔑 —

React Auth Kit is Apache 2.0 License code